New Android SDK/ADT, Eclipse Indigo, and related issues

Within the past few days Google has released r12 of the Android SDK and the Eclipse ADT plugin. Unlike r11, a parallel upgrade of the SDK and ADT isn't required, but is recommended. The only significant change in this release for the SDK is:
The AVD manager and emulator can now use system images compiled for ARM v7 and x86 CPUs.

The ADT got a few minor improvements, such as previews for drawables and colors in the Resource Chooser dialog. One other item of note is:
A new option lets you disable the packaging step in the automatic builders. This improves performance when saving files by not performing a full build, which can take a long time for large projects. If the option is enabled, the APK is packaged when the application is deployed to a device or emulator or when the release APK is exported.

I also installed Eclipse Indigo (version 3.7) yesterday and have started to test it out for use. Overall, I don't notice any difference at all compared to the Galileo (version 3.5) install I have been using for months. I did a quick review of the release notes, and it seems as though the significant changes are in the Java development related projects, none of which seem to affect my Android development.

I am disappointed that all of these new releases failed to fix a couple of problems I've been having with Eclipse and ADT. Specifically, I'm experiencing these problems, both in Galileo/ADT r11 and Indigo/ADT r12:

  • At least once a day -- and usually more frequently -- Eclipse just goes berserk and starts consuming 100%+ CPU (as reported on my dual core Mac's Activity Manager). The only solution I've found is to restart Eclipse.

  • Within the past few weeks (and so perhaps related to the ADT r11/r12 update), Eclipse is having issues importing projects. Specifically, it believes that an imported Android project does not have the proper Java compiler compliance setting, and I get tons of errors saying that compiler compliance level 5.0 or 6.0 is required. This is despite my Eclipse workspace having its compliance level set to 1.6, and the imported project not enabling project specific settings (the Project Properties dialog shows the checkbox as unchecked, and the disabled Compiler compliance level drop-down shows 1.6). The only fix I've been able to find is to enable project specific Java Compiler settings, explicitly set the compiler compliance level to something like 1.5 and Apply, then reset it back to 1.6 and Apply.

Copyright © 2018 ProTech. All Rights Reserved.

Sign In Create Account

Navigation

Social Media